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Extrae features

• Platforms

• Intel, Cray, BlueGene, MIC, ARM, Android, Fujitsu Sparc …

• Parallel programming models

• MPI, OpenMP, pthreads, OmpSs, CUDA, OpenCL, Java, Python …

• Performance Counters

• Using PAPI interface

• Link to source code

• Callstack at MPI routines

• OpenMP outlined routines

• Selected user functions (Dyninst)

• Periodic sampling

• User events (Extrae API)
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No need 
to

recompile 
or relink!



How does Extrae work?

• Symbol substitution through LD_PRELOAD
• Specific libraries for each combination of runtimes

• MPI

• OpenMP

• OpenMP+MPI

• …

• Dynamic instrumentation
• Based on Dyninst (developed by U.Wisconsin / U.Maryland)

• Instrumentation in memory

• Binary rewriting

• Alternatives
• Static link (i.e., PMPI, Extrae API)
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Recommended



Using Extrae in 3 steps

1. Adapt your job submission scripts

2. Configure what to trace

• XML configuration file

• Example configurations  at $EXTRAE_HOME/share/example

3. Run it!

• For further reference check the Extrae User Guide:

• https://tools.bsc.es/doc/html/extrae

• Also distributed with Extrae at $EXTRAE_HOME/share/doc
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https://tools.bsc.es/doc/%5Bhtml


Log in to Jusuf

• The following directory contains all the examples:
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laptop$ ssh –Y <USER>@jusuf.fz-juelich.de

jusuf$ cp –r /p/project/training2214/tools-material 
$HOME

jusuf$ ls –l $HOME/tools-material
bin/
clustering/
extrae/
slides/
traces/

Here you have a copy of this slides.
Copy them to your laptop 

or open remotely with:

> evince slides/Extrae-Paraver-Hands-
On.pdf



Step 1: Adapt the job script to load Extrae
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#!/bin/bash -x
#SBATCH --account=training2214
#SBATCH --nodes=1
#SBATCH --ntasks=27
#SBATCH --cpus-per-task=1
#SBATCH --output=lulesh2.0_27p.%j
#SBATCH --error=lulesh2.0_27p.%j
#SBATCH --time=00:10:00
#SBATCH --partition=batch

export OMP_NUM_THREADS=${SLURM_CPUS_PER_TASK}

srun --cpu-bind=cores ../bin/lulesh2.0 -i 10 -s 65 -p

Request resources

Run the program

jusuf$ vi $HOME/tools-material/extrae/job_27p.sh



Step 1: Adapt the job script to load Extrae
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#!/bin/bash -x
#SBATCH --account=training2214
#SBATCH --nodes=1
#SBATCH --ntasks=27
#SBATCH --cpus-per-task=1
#SBATCH --output=lulesh2.0_27p.%j
#SBATCH --error=lulesh2.0_27p.%j
#SBATCH --time=00:10:00
#SBATCH --partition=batch

export OMP_NUM_THREADS=${SLURM_CPUS_PER_TASK}

srun --cpu-bind=cores ./trace.sh ../bin/lulesh2.0_i 
…

jusuf$ vi $HOME/tools-material/extrae/job_27p.sh

Run with Extrae



Step 1: Adapt the job script to load Extrae
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#!/bin/bash -x
#SBATCH --account=training2214
#SBATCH --nodes=1
#SBATCH --ntasks=27
#SBATCH --cpus-per-task=1
#SBATCH --output=lulesh2.0_27p.%j
#SBATCH --error=lulesh2.0_27p.%j
#SBATCH --time=00:10:00
#SBATCH --partition=batch

export OMP_NUM_THREADS=${SLURM_CPUS_PER_TASK}

srun --cpu-bind=cores ./trace.sh ../bin/lulesh2.0_i 
…

jusuf$ vi $HOME/tools-material/extrae/trace.sh

#!/usr/bin/env bash

module load GCC ParaStationMPI Extrae

export 
EXTRAE_HOME=/p/software/jusuf/stages/2022/softwar
e/Extrae/3.8.3-gpsmpi-2021b

export TRACE_NAME=lulesh2.0_27p.prv

# Configure Extrae
export EXTRAE_CONFIG_FILE=extrae.xml

# Load the tracing library (choose C/Fortran)
export LD_PRELOAD=$EXTRAE_HOME/lib/libmpitrace.so
#export 
LD_PRELOAD=$EXTRAE_HOME/lib/libmpitracef.so

# Run the program
$*

What to trace?

Type of application

Load Extrae



Step 1: Which tracing library?

• Choose depending on the application type
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Library Serial MPI OpenMP pthread CUDA

libseqtrace x
libmpitrace[f]1 x
libomptrace x
libpttrace x
libcudatrace x
libompitrace[f] 1 x x
libptmpitrace[f] 1 x x
libcudampitrace[f] 1 x x

1 include suffix “f” in Fortran codes



Step 2: Extrae XML configuration
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  <mpi enabled="yes">
    <counters enabled="yes" />
  </mpi>

  <openmp enabled="no">
    <locks enabled="no" />
    <counters enabled="yes" />
  </openmp>

  <pthread enabled="no">
    <locks enabled="no" />
    <counters enabled="yes" />
  </pthread>

  <callers enabled="yes">
    <mpi enabled="yes">1-3</mpi>
    <sampling enabled="no">1-5</sampling>
  </callers>

Trace the MPI calls 
(What’s the program doing?)

Trace the call-stack 
(Where in my code?)

jusuf$ vim $HOME/tools-material/extrae/extrae.xml



Step 2: Extrae XML configuration (II)
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<counters enabled="yes">
    <cpu enabled="yes" starting-set-distribution="1">
      <set enabled="yes" domain="all" changeat-time="0">
        PAPI_TOT_INS,PAPI_TOT_CYC
      </set>
    </cpu>
    <network enabled="no" />
    <resource-usage enabled="no" />
    <memory-usage enabled="no" />
  </counters>

Select which 
HW counters
are measured

(How’s the machine doing?)

jusuf$ vi $HOME/tools-material/extrae/extrae.xml



Step 2: Extrae XML configuration (III)

12

  <buffer enabled="yes">
    <size enabled="yes">500000</size>
    <circular enabled="no" />
  </buffer>
 
  <sampling enabled="no" type="default" period="50m" variability="10m" />

  <merge enabled="yes" 
    synchronization="default"
    tree-fan-out="16"
    max-memory="512"
    joint-states="yes"
    keep-mpits="yes"
    sort-addresses="yes"
    overwrite="yes"> 
    $TRACE_NAME$
  </merge>

Trace buffer size
(Flush/memory trade-off)

Enable sampling
(Want more details?)

Automatic 
post-processing 
to generate the 

Paraver trace

jusuf$ vi $HOME/tools-material/extrae/extrae.xml



Step 3: Run it!

• Submit your job

• Easy!
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jusuf$ cd $HOME/tools-material/extrae
jusuf$ sbatch job_27p.sh



All done! Check your resulting trace

• Once finished (check with “squeue”) you will have the trace (3 files):

• Any trouble? Traces already generated here:

• Now let’s look into it !
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jusuf$ ls –l $HOME/tools-material/extrae
lulesh2.0_i_27p.pcf
lulesh2.0_i_27p.prv
lulesh2.0_i_27p.row

jusuf$ ls $HOME/tools-material/traces



Install Paraver

• Download from https://tools.bsc.es/downloads
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Pick your version

wxparaver-4.10.0-win.zip

wxparaver-4.10.0-mac.zip

wxparaver-4.10.0-Linux_x86_64.tar.gz (64-bits)

wxparaver-4.10.0-Linux_i686.tar.gz (32-bits)

https://tools.bsc.es/downloads


Install Paraver (II)
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  laptop$ tar xf wxparaver-4.10.0-linux-
x86_64.tar.gz 
  laptop$ mv wxparaver-4.10.0-linux-x86_64 paraver

• Start Paraver

laptop$ paraver/bin/wxparaver

jusuf$ wxparaver

• Trouble installing locally? Remote open from Jusuf



Install Paraver tutorials (I)

• Download tutorials:
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Click on Help  
Tutorials

Tutorials window 
will pop-up

Tutorials

Tutorials down…

Follow these tutorials by clicking on the hyperlinks and reading the explanations. When 
you click on a link, multiple views will open.



Install Paraver tutorials – alternative 
methods(II)
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 Download tutorials archive
 https://tools.bsc.es/paraver-tutorials

paraver-tutorials-20150526.tar.gz

All tutorials

https://tools.bsc.es/paraver-tutorials


Install Paraver tutorials – alternative 
methods(III)
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 Start Paraver:
 Linux: Run the command:

 Windows: Double-click on 
paraver/wxparaver.exe

 MAC: Double click on 
paraver/wxparaver.app

 Open File → Preferences
Setup the “Tutorials root” pointing to 
your folder “tutorials”

 laptop$ paraver/bin/wxparaver

Click Browse and 
select your folder 

“tutorials”



First steps of analysis

• Copy the trace to your laptop

• Load the trace with Paraver

20

laptop$ scp <USER>@jusuf.fz-juelich.de: \
tools-material/extrae/lulesh2.0_i_27p.* $HOME

Click on File → Load Trace 
 →  Browse to 

“lulesh2.0_i_27p.prv”



First steps of analysis

• Follow Tutorial #3
• Introduction to Paraver and Dimemas methodology

Click on Help → Tutorials
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Measure the parallel efficiency

• Click on “mpi_stats.cfg”
• Check the Average for the column labeled “Outside MPI”
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Load balance

Parallel efficiency

Comm efficiency



Focus on the iterative part
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Click on "Open 
Control Window"

Zoom iterative part



Recalculate efficiency of iterative region
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Right click -> Copy

Right click -> 
Paste -> Time

Load balance

Parallel efficiency

Comm efficiency



Computation time distribution

• Click on “2dh_usefulduration.cfg” (2nd link)  Shows time computing
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Right click -> Paste -> Time
(to focus on the iterative part)



Computation time distribution

• Click on “2dh_usefulduration.cfg” (2nd link)  Shows time computing
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Zoom in 



Computation time distribution

• Click on “2dh_usefulduration.cfg” (2nd link)  Shows time computing
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Performance 
Imbalance
(zig-zag)



Computation load distribution

• Click on “2dh_useful_instructions.cfg” (3rd link)  Shows amount of work
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Focus only on the iteration part 
(copy time and zoom done)

Work imbalance 
(zig-zag)

Good work
distribution
(straight line)



Where does this happen?
• Go from the table to the timeline
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1. Click on 
“Open Filtered Control 

Window”

2. Select this area
(by drag-and-dropping)

 Right click 
→  Fit Semantic Scale 

→ Fit both



Where does this happen?
• Go from the table to the timeline
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1. Click on 
“Open Filtered Control 

Window”

2. Select this area
(by drag-and-dropping)

 Right click 
→  Fit Semantic Scale 

→ Fit both



Where does this happen?

•             &             at the same time?  Imbalance
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Zoom into
1 of the iterations

(by drag-and-dropping)

Slow Fast



Where does this happen?

• Hints →  Call stack references →  Caller function

32

Right click → Copy
Right click 

→ Paste →  Time



Where does this happen?

• Hints →  Call stack references →  Caller function
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Save CFG’s (2 methods)
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Right click on 
timeline



Save CFG’s (2 methods)
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1. Main Paraver 
window

2. Select

3. Save



CFG’s distribution

• Paraver comes with many more included CFG’s

36



Hints: a good place to start!

• Paraver suggests CFG’s based on the contents of the trace
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Takeaway: Analyse 
efficiencies and 

unbalances

Judit Giménez, Germán Llort, Lau Mercadal, 
Sandra Méndez

19/04/2021 POP Performance Analysis

tools@bsc.es

mailto:tools@bsc.es


Clustering
Hands-On

Judit Giménez, Germán Llort, Lau Mercadal, 
Sandra Méndez

19/04/2021 POP Performance Analysis

tools@bsc.es

mailto:tools@bsc.es


Cluster-based analysis (I)

• Run the clustering tool on the trace you generated

• If you didn’t get your own trace, use a prepared one from:
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  jusuf$ source /p/project/training2214/setup.sh 
  jusuf$ cd $HOME/tools-material/clustering
  jusuf$ BurstClustering \ 
  -d cluster.xml \
  -i ../extrae/lulesh2.0_i_27p.prv \
  -o lulesh2.0_i_27p-clustered.prv

  jusuf$ ls 
$HOME/tools-material/traces/lulesh2.0_i_27p.prv



Cluster-based analysis (II)

• Check the clustering scatter plot

• Identify main computing trends

• Work (Y) vs. Performance (X)

• Look at the clusters shape

• Variability in both axes 

indicate potential imbalances
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jusuf$ gnuplot \
lulesh2.0_i_27p-clustered.IPC.PAPI_TOT_INS.gnuplot



Cluster-based analysis (III)
• Check the clustered trace

• Copy the trace to your laptop

• Load with Paraver

• Display the distribution of clusters over time

• File  Load configuration   paraver/cfgs/clustering/clusterID_window.cfg
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jusuf$ scp <USER>@jusuf.fz-juelich.de: \
tools-material/clustering/*.{pcf,prv,row} $HOME 

laptop$ paraver/bin/wxparaver \
$HOME/lulesh2.0_i_27p_clustered.prv
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Cluster-based analysis (III)

• Correlate scatter plots & timelines to detect imbalances

Variable work
and/or

Variable speed
+

Simultaneously @ different processes
=

Imbalances

Zoom into
1 of the iterations

(by drag-and-
dropping)



End Clustering
Hands-On
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