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Extrae features

• Platforms

• Intel, Cray, BlueGene, MIC, ARM, Android, Fujitsu Sparc …

• Parallel programming models

• MPI, OpenMP, pthreads, OmpSs, CUDA, OpenCL, Java, Python …

• Performance Counters

• Using PAPI interface

• Link to source code

• Callstack at MPI routines

• OpenMP outlined routines

• Selected user functions (Dyninst)

• Periodic sampling

• User events (Extrae API)
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No need 
to

recompile 
or relink!

No need 
to

recompile 
or relink!



How does Extrae work?

• Symbol substitution through LD_PRELOAD
• Specific libraries for each combination of runtimes

• MPI

• OpenMP

• OpenMP+MPI

• …

• Dynamic instrumentation
• Based on Dyninst (developed by U.Wisconsin / U.Maryland)

• Instrumentation in memory

• Binary rewriting

• Alternatives
• Static link (i.e., PMPI, Extrae API)
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RecommendedRecommended



Using Extrae in 3 steps

1. Adapt your job submission scripts

2. Configure what to trace

• XML configuration file

• Example configurations  at $EXTRAE_HOME/share/example

3. Run it!

• For further reference check the Extrae User Guide:

• https://tools.bsc.es/doc/html/extrae

• Also distributed with Extrae at $EXTRAE_HOME/share/doc
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https://tools.bsc.es/doc/%5Bhtml


Log in to MareNostrum4

• The following directory contains all the examples:

5

laptop$ ssh –Y <USER>@mn1.bsc.es

mn$ cp –R /home/nct00/nct00003/tools-material 
$HOME
mn$ ls –l $HOME/tools-material
bin/
clustering/
extrae/
slides/
traces/

Here you have a copy of this slides.
Copy them to your laptop 

or open remotely with:

> evince slides/Extrae-Paraver-Hands-
On.pdf

Here you have a copy of this slides.
Copy them to your laptop 

or open remotely with:

> evince slides/Extrae-Paraver-Hands-
On.pdf



Step 1: Adapt the job script to load Extrae
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#!/usr/bin/env bash

#SBATCH --job-name=lulesh2.0_i_27p
#SBATCH --output=lulesh2.0_i_27p.out
#SBATCH --error=lulesh2.0_i_27p.err
#SBATCH --ntasks=27
#SBATCH --cpus-per-task=1
#SBATCH --time=00:10:00
#SBATCH --exclusive
#SBATCH --reservation=Training21

export OMP_NUM_THREADS=1

srun --cpu-bind=cores ../bin/lulesh2.0_i -i 10 -s 
65 -p

Request resourcesRequest resources

Run the programRun the program

mn$ vi $HOME/tools-material/extrae/job_27p.sh



Step 1: Adapt the job script to load Extrae
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#!/usr/bin/env bash

#SBATCH --job-name=lulesh2.0_i_27p
#SBATCH --output=lulesh2.0_i_27p.out
#SBATCH --error=lulesh2.0_i_27p.err
#SBATCH --ntasks=27
#SBATCH --cpus-per-task=1
#SBATCH --time=00:10:00
#SBATCH --exclusive
#SBATCH --reservation=Training21

export OMP_NUM_THREADS=1

srun --cpu-bind=cores ./trace.sh ../bin/lulesh2.0_i 
…

mn$ vi $HOME/tools-material/extrae/job_27p.sh

Run with ExtraeRun with Extrae



Step 1: Adapt the job script to load Extrae
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#!/usr/bin/env bash

#SBATCH --job-name=lulesh2.0_i_27p
#SBATCH --output=lulesh2.0_i_27p.out
#SBATCH --error=lulesh2.0_i_27p.err
#SBATCH --ntasks=27
#SBATCH --cpus-per-task=1
#SBATCH --time=00:10:00
#SBATCH --exclusive
#SBATCH --reservation=Training21

export OMP_NUM_THREADS=1

srun --cpu-bind=cores ./trace.sh ../bin/lulesh2.0_i 
…

mn$ vi $HOME/tools-material/extrae/trace.sh

#!/usr/bin/env bash

module load gcc/7.2.0 EXTRAE/3.8.3
export TRACE_NAME=lulesh2.0_27p.prv

# Configure Extrae
export EXTRAE_CONFIG_FILE=extrae.xml

# Load the tracing library (choose C/Fortran)
export 
LD_PRELOAD=$EXTRAE_HOME/lib/libmpitrace.so
#export 
LD_PRELOAD=$EXTRAE_HOME/lib/libmpitracef.so

# Run the program
$*

#!/usr/bin/env bash

module load gcc/7.2.0 EXTRAE/3.8.3
export TRACE_NAME=lulesh2.0_27p.prv

# Configure Extrae
export EXTRAE_CONFIG_FILE=extrae.xml

# Load the tracing library (choose C/Fortran)
export 
LD_PRELOAD=$EXTRAE_HOME/lib/libmpitrace.so
#export 
LD_PRELOAD=$EXTRAE_HOME/lib/libmpitracef.so

# Run the program
$*

What to trace?What to trace?

Type of applicationType of application

Load ExtraeLoad Extrae



Step 1: Which tracing library?

• Choose depending on the application type
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Library Serial MPI OpenMP pthread CUDA

libseqtrace x
libmpitrace[f]1 x
libomptrace x
libpttrace x
libcudatrace x
libompitrace[f] 1 x x
libptmpitrace[f] 1 x x
libcudampitrace[f] 1 x x

1 include suffix “f” in Fortran codes



Step 3: Run it!

• Submit your job

• Easy!
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mn$ cd $HOME/tools-material/extrae

mn$ sbatch job_27p.sh



Step 2: Extrae XML configuration
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  <mpi enabled="yes">
    <counters enabled="yes" />
  </mpi>

  <openmp enabled="no">
    <locks enabled="no" />
    <counters enabled="yes" />
  </openmp>

  <pthread enabled="no">
    <locks enabled="no" />
    <counters enabled="yes" />
  </pthread>

  <callers enabled="yes">
    <mpi enabled="yes">1-3</mpi>
    <sampling enabled="no">1-5</sampling>
  </callers>

Trace the MPI calls 
(What’s the program doing?)

Trace the MPI calls 
(What’s the program doing?)

Trace the call-stack 
(Where in my code?)

Trace the call-stack 
(Where in my code?)

mn$ vi $HOME/tools-material/extrae/extrae.xml



Step 2: Extrae XML configuration (II)
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<counters enabled="yes">
    <cpu enabled="yes" starting-set-distribution="1">
      <set enabled="yes" domain="all" changeat-time="0">
        PAPI_TOT_INS,PAPI_TOT_CYC
      </set>
    </cpu>
    <network enabled="no" />
    <resource-usage enabled="no" />
    <memory-usage enabled="no" />
  </counters>

Select which 
HW counters
are measured

(How’s the machine doing?)

Select which 
HW counters
are measured

(How’s the machine doing?)

mn$ vi $HOME/tools-material/extrae/extrae.xml



Step 2: Extrae XML configuration (III)
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  <buffer enabled="yes">
    <size enabled="yes">500000</size>
    <circular enabled="no" />
  </buffer>
 
  <sampling enabled="no" type="default" period="50m" variability="10m" />

  <merge enabled="yes" 
    synchronization="default"
    tree-fan-out="16"
    max-memory="512"
    joint-states="yes"
    keep-mpits="yes"
    sort-addresses="yes"
    overwrite="yes"> 
    $TRACE_NAME$
  </merge>

Trace buffer size
(Flush/memory trade-off)

Trace buffer size
(Flush/memory trade-off)

Enable sampling
(Want more details?)

Enable sampling
(Want more details?)

Automatic 
post-processing 
to generate the 

Paraver trace

mn$ vi $HOME/tools-material/extrae/extrae.xml



All done! Check your resulting trace

• Once finished (check with “squeue”) you will have the trace (3 files):

• Any trouble? Traces already generated here:

• Now let’s look into it !
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mn$ ls –l $HOME/tools-material/extrae
lulesh2.0_i_27p.pcf
lulesh2.0_i_27p.prv
lulesh2.0_i_27p.row

mn$ ls $HOME/tools-material/traces



Install Paraver

• Download from https://tools.bsc.es/downloads

• Also available @MN4
• $HOME/tools-packages
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Pick your versionPick your version

 laptop$ scp <USER>@mn1.bsc.es:tools-packages/<PKG> 
.

wxparaver-4.9.2-win.zip

wxparaver-4.9.2-mac.zip

wxparaver-4.9.2-Linux_x86_64.tar.gz (64-bits)

wxparaver-4.9.2-Linux_i686.tar.gz (32-bits)

https://tools.bsc.es/downloads


Install Paraver (II)
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  laptop$ tar xf wxparaver-4.9.2-linux-x86_64.tar.gz 

  laptop$ mv wxparaver-4.9.2-linux-x86_64 paraver

• Start Paraver

laptop$ paraver/bin/wxparaver

mn$ module load paraver

mn$ wxparaver

• Trouble installing locally? Remote open from MareNostrum4



Install Paraver tutorials (I)

• Download tutorials:
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Click on Help  
Tutorials

Click on Help  
Tutorials

Tutorials window 
will pop-up

Tutorials window 
will pop-up

Tutorials

Tutorials down…

Follow these tutorials by clicking on the hyperlinks and reading the explanations. When 
you click on a link, multiple views will open.



Install Paraver tutorials – alternative 
methods(II)
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 Download tutorials archive
 https://tools.bsc.es/paraver-tutorials

paraver-tutorials-20150526.tar.gzparaver-tutorials-20150526.tar.gz

All tutorialsAll tutorials

https://tools.bsc.es/paraver-tutorials


Install Paraver tutorials – alternative 
methods(III)
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 Start Paraver:
 Linux: Run the command:

 Windows: Double-click on 
paraver/wxparaver.exe

 MAC: Double click on 
paraver/wxparaver.app

 Open File → Preferences
Setup the “Tutorials root” pointing to 
your folder “tutorials”

 laptop$ paraver/bin/wxparaver

Click Browse and 
select your folder 

“tutorials”

Click Browse and 
select your folder 

“tutorials”



First steps of analysis

• Copy the trace to your laptop

• Load the trace with Paraver
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laptop$ scp <USER>@mn1.bsc.es: \
tools-material/extrae/lulesh2.0_i_27p.* $HOME

Click on File → Load Trace 
 →  Browse to 

“lulesh2.0_i_27p.prv”

Click on File → Load Trace 
 →  Browse to 

“lulesh2.0_i_27p.prv”



First steps of analysis

• Follow Tutorial #3
• Introduction to Paraver and Dimemas methodology

Click on Help → TutorialsClick on Help → Tutorials

21



Measure the parallel efficiency

• Click on “mpi_stats.cfg”
• Check the Average for the column labeled “Outside MPI”
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Load balance

Parallel efficiency

Comm efficiency



Computation time distribution

• Click on “2dh_usefulduration.cfg” (2nd link)  Shows time computing
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Performance 
imbalance

(zig-zag)

Performance 
imbalance

(zig-zag)



Computation load distribution

• Click on “2dh_useful_instructions.cfg” (3rd link)  Shows amount of work
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Work 
imbalance

(zig-zag)

Work 
imbalance

(zig-zag)

Good work 
distribution
(straight line)

Good work 
distribution
(straight line)

But…

Then…



Where does this happen?

• Go from the table to the timeline
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Click on 
“Open Filtered 

Control Window”

Click on 
“Open Filtered 

Control Window”

Select this area
(by drag-and-dropping)

Select this area
(by drag-and-dropping)

     Right click
 →  Fit Semantic Scale
 → Fit both

     Right click
 →  Fit Semantic Scale
 → Fit both



Where does this happen?

•             &             at the same time?  Imbalance
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Zoom into

1 of the iterations
(by drag-and-dropping)

Zoom into

1 of the iterations
(by drag-and-dropping)

SlowSlow FastFast



CommMonoQ

Where does this happen?

• Hints →  Call stack references →  Caller function
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TimeIncrementCommSendCommRecv

Right click → CopyRight click → Copy
Right click 

→ Paste →  Time

Right click 
→ Paste →  Time



Save CFG’s (2 methods)
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Right click on 
timeline

Right click on 
timeline



Save CFG’s (2 methods)
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1. Main Paraver 
window

1. Main Paraver 
window

2. Select2. Select

3. Save3. Save



CFG’s distribution

• Paraver comes with many more included CFG’s
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Hints: a good place to start!

• Paraver suggests CFG’s based on the contents of the trace

31



Takeaway: Analyse 
efficiencies and 

unbalances
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Clustering
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Cluster-based analysis (I)

• Run the clustering tool on the trace you generated

• If you didn’t get your own trace, use a prepared one from:
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  mn$ module load clustering_suite

  mn$ cd $HOME/tools-material/clustering

  mn$ BurstClustering \ 
  -d cluster.xml \
  -i ../extrae/lulesh2.0_i_27p.prv \
  -o lulesh2.0_i_27p_clustered.prv

  mn$ ls 
$HOME/tools-material/traces/lulesh2.0_i_27p.prv



Cluster-based analysis (II)

• Check the clustering scatter plot

• Identify main computing trends

• Work (Y) vs. Performance (X)

• Look at the clusters shape

• Variability in both axes 

indicate potential imbalances
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mn$ gnuplot \
lulesh2.0_i_27p_clustered.IPC.PAPI_TOT_INS.gnuplo

t



Cluster-based analysis (III)

• Check the clustered trace

• Copy the trace to your laptop

• Load with Paraver

• Display the distribution of clusters over time

• File  Load configuration   paraver/cfgs/clustering/clusterID_window.cfg
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mn$ scp <USER>@mn1.bsc.es: \
tools-material/clustering/*.{pcf,prv,row} $HOME 

laptop$ paraver/bin/wxparaver \
$HOME/lulesh2.0_i_27p_clustered.prv
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Cluster-based analysis (III)

• Correlate scatter plots & timelines to detect imbalances

Variable work
and/or

Variable speed
+

Simultaneously @ different processes
=

Imbalances

Variable work
and/or

Variable speed
+

Simultaneously @ different processes
=

Imbalances
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